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Feature Fills: Enhanced support for continuous systems like battery
models

In R2022b, Model-Based Calibration Toolbox includes enhanced support for continuous systems like
battery models. Specifically, feature filling includes support for:

+ Simulink® models with first-order transient systems

» Data containing variable sample rates

* Setting initial conditions
Simulink Models with First-Order Transient Systems
Transient calibration includes enhanced support for Simulink models with continuous first-order

transient systems, including battery models. The Continuous First-Order System block in the
cgeqlib library has these Integration Method settings.

Setting Use Considerations
Forward Euler * Most continuous first-order systems
Backward Euler * Feed-forward systems

* Provides numerical stability for feature filling when the sample
time is large, including variable sample time

Trapezoidal * Feed-forward systems

* Provides numerical stability for feature filling when the sample
time is large, including variable sample time

Exponential Euler * Constant time constant

* Slowly time-varying time constant

Previously, the Continuous First-Order System block provided only forward Euler integration. For
sample rates that are too high, forward Euler integrations can be unstable, leading to infinite
responses during optimization.

For more information, see “Block Support”.
Data Containing Variable Sample Rates

If you import a Simulink model with a transient block, the CAGE Parser dialog box prompts you to set
the data sample rate.

For data with a variable sample rate, set the value to -1 or 0.

* The data file must contain a signal named time. After you import the strategy, you can use the
CAGE variable dictionary to rename the time signal.

» To calculate the sample time, CAGE uses a discrete filter.

* Battery characterization tests can have variable same rates. The tests are long running and
consist of a transient response requiring a fast sample time (0.01 to 0.1s), followed by near
steady-state conditions that are sampled at a lower rate.

For more information, see “Import Simulink Model”.




Set Initial Conditions

When you run the optimization for a transient calibration, you can use the Feature Fill Wizard to set
the initial conditions for states, either:

* Value - Constant value
* Data - First specified signal value in data file

4 Feature Fill Wizard — O >

Data setup
Select data folder and =signals.

Data folder: Folder. Chwork\BatteryPulzeData

File extension: C8Y o

File
1 PulzeData.cav

Reference wvariable: W o
Data comparison: all values e 0 :
Initial conditions

State Value Data
Charge_accumulator 10,0058 <none= v
Continuous_First_order_System 0 <none= w
Continuous_First_order_System 0 =none= e
Continuous_First_order_System 0 <none= w

Cancel < Back Next = Finigh

For more information, see “Run Optimization”.
Feature Fills: Support for 3-D tables, including battery tables that are
functions of SOC, temperature, and current

Feature fills include support for 3-D lookup tables, including battery tables that are functions of state
of charge (SOC), temperature, and current. You can:

 Fill 3-D lookup tables from data.
* Smooth surfaces using Chebyshev polynomial or spline approximations.

1-3
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* Visualize and edit 3-D lookup tables and extrapolate smoothly.

Use the Slice Selector options to preview the table 3-D table. Specify the X, Y and Z-axes for the
Z-axis break points, providing a slice view of the data.

Lookup Table Preview  Calibration Scalars  Validation

Lookup Tables Edit Lookup Table
Mame Statuz
[Tl NDTable Imported from
Simulink model
2 Indtestloop
£
m
/ :
=
Slice Selector
H-Axis: XBrkpts ~
Y-Axis: Y Brkptz b
ZBrkpts 450 s | YBrkpts(Spead) 00 wEkpte(LOAD)

The Lookup Table Preview and Lookup Tables view provide Slice Selector options for 3-D
tables.

* Export the table values and dimensions to:

* Simulink model workspace data
* Simulink data dictionary
¢ MATLAB® matrix

For more information, see “Lookup Tables, Normalizers, and Constants”.

Transient Calibration: Use analytic Hessians to find optimal solutions

You can now use analytic Hessians when you use feature filling to run the optimization. In the Feature
Fill Wizard, for the Algorithm parameter, select Analytic Hessian (slow). Previously, the
options were ADAM, Nonlinear least squares, and Eigenvalue analysis-based
optimization scheme.

Consider using Analytic Hessian (slow) if the other methods fail to find a satisfactory solution.
Although this option can be significantly slower than other methods, it can converge on a solution
when other methods fail. This method is useful when the initial lookup table values are not close to
the optimal solution. You may need a combination of different methods to obtain a solution. Start with
the default ADAM method.

1-4



(4 Feature Fill Wizard — O >

Large scale feature fill
Select large scale optimization settings.

Mumber of iterations: 100 = Smoothing factor: le-4/=
Learning rate: 1 : Algorithm: Monlinear leas...
. e AlAM
Weight factor: 1.2} Optimize simultaneou )
MNenlinear least squares
Lookup table approxim... |linear e |:| Save coefficients as 1 Eigenvalue analysis-based optimization scheme

For more information, see “Run Optimization”.
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Transient Calibration: Faster optimization for Simulink models with
first-order transient systems

Transient calibration includes enhanced support for Simulink models with first-order transient
systems. CAGE includes blocks that create a single top-level feature for the first-order transient
system, which improves the optimization performance. Use the first-order system to estimate time
constants and gains specified by lookup tables or scalars in CAGE.

Previously, if your Simulink model contained a feedback loop, the CAGE implementation resulted in
slow feature evaluation. In R2022a, CAGE provides a 30% to 50% increase in evaluating features with
feedback loops.

For more information, see Optimize Calibrations with Transient Controllers.

Transient Calibration: Faster optimization for feature fills with many
lookup tables

Transient calibration includes an optimization algorithm for feature fills with many lookup tables to
fill. To use the algorithm, set Algorithm to Eigenvalue analysis-based optimization
scheme. Consider this option for feature fills with many lookup tables to fill when the default ADAM
algorithm has poor convergence and the Nonlinear least squares algorithm is slow.

Previously, you could select only ADAM or Nonlinear least squares optimization algorithms.

For more information, see Optimize Calibrations with Transient Controllers.

Transient Calibration: Optimize ECU lookup tables using spline
interpolation

During transient calibration, you can optimize engine control unit (ECU) lookup tables using spline

interpolation, linear interpolation, or Chebyshev polynomials. Previously, you could only use
Chebyshev polynomials as an alternative to linear interpolation of lookup tables.

For more information, see Optimize Calibrations with Transient Controllers.

Battery Calibration: Characterize an Equivalent Circuit Battery

Using MathWorks® tools, estimation techniques, and measured lithium-ion or lead acid battery data,
you can use CAGE to characterize a resistor-capacitor (RC) circuit battery with open circuit voltage,
series resistance, and 1 through N RC pairs. For an example, see Characterize an Equivalent Circuit
Battery.


https://www.mathworks.com/help/releases/R2022a/mbc/calibrate/fill-transient-feature.html
https://www.mathworks.com/help/releases/R2022a/mbc/calibrate/fill-transient-feature.html
https://www.mathworks.com/help/releases/R2022a/mbc/calibrate/fill-transient-feature.html
https://www.mathworks.com/help/releases/R2022a/mbc/calibrate/characterize-an-equivalent-circuit-battery.html
https://www.mathworks.com/help/releases/R2022a/mbc/calibrate/characterize-an-equivalent-circuit-battery.html
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Transient Calibration: Simplified workflow and robust algorithms for
large-scale optimizations

Transient calibration includes robust algorithms for large-scale optimizations. The feature fill allows
you to:

* Select either adaptive moment estimation (ADAM) or nonlinear least squares for the optimization
Algorithm parameter. Previously, the least squares algorithm was the only available large-scale
optimization algorithm.

* ADAM (default) - Algorithm that is typically more robust in the initial search for an optimization
solution. Use for large optimization problems with large data sets and many parameters. Use in
deep learning applications. For more information, see Deep Learning Toolbox Applications
(Deep Learning Toolbox).

* Least squares - Algorithm that has faster convergence. Use when the table values are close
to the optimal values.

* Use the Data comparison parameter to compare all values orthe final value in the data
set to a reference signal. Previously, the Feature Fill wizard had a check box to use only the final
value for the comparison.

* Specify a Learning rate parameter for the ADAM algorithm. If you select the least squares
algorithm, the Learning rate parameter corresponds to the step size.

* For Least squares optimizations, select Optimize simultaneously to account for lookup table
couplings. Selecting this option might produce more accurate optimizations but slow performance.

R2021b includes a simplified transient calibration workflow. When you optimize transient calibrations
using large-scale feature fill, you can:

* Use optimization weights from a previous optimization.

* Update the lookup table breakpoints if the test data covers less than half the table data.

* Monitor the change in parameter values on a Fill Progress window.

If you import a Simulink model with a transient block, CAGE prompts you to select if you want to
create a transient or steady-state feature fill.

For more information, see Optimize Calibrations with Transient Controllers.

Transient Calibration: Simplified workflow for production calibration
using calibration parameter files

CAGE provides a simplified workflow for dynamic production calibration of vehicle components such
as throttle and EGR control. Specifically, CAGE simplifies the workflow for working with calibration
data. You can:

* Use a calibration data file to optimize and initialize all lookup tables and scalars for a feature fill.
You can specify lookup tables and scalars that you want to adjust when you use feature filling.
Previously, you had to manually adjust the tables and scalars. For more information, see Optimize
Calibrations with Transient Controllers.

» Import or export a calibration to a INCA CSV file data file. For more information, see Import
and Export Calibrations.


https://www.mathworks.com/help/releases/R2021b/deeplearning/gs/shallow-networks-for-pattern-recognition-clustering-and-time-series.html#f9-36282
https://www.mathworks.com/help/releases/R2021b/mbc/calibrate/fill-transient-feature.html
https://www.mathworks.com/help/releases/R2021b/mbc/calibrate/fill-transient-feature.html
https://www.mathworks.com/help/releases/R2021b/mbc/calibrate/fill-transient-feature.html
https://www.mathworks.com/help/releases/R2021b/mbc/calibrate/importing-and-exporting-calibrations.html
https://www.mathworks.com/help/releases/R2021b/mbc/calibrate/importing-and-exporting-calibrations.html

* Automatically export the calibration data after an optimization. For more information, see
Optimize Calibrations with Transient Controllers.

Calibration History: Restore previous calibrations, including lookup
tables, normalizers, and scalars

CAGE allows you to restore previous calibrations and calibrations items, including tables,
normalizers, and scalars. You can restore previous calibrations from:

* Optimizations

» Feature fills

* Imported calibration data files

To restore a previous calibration in CAGE, select Tools > Calibration History. Use the dialog box to
select the calibration and calibration items.

# Calibration History - O x

Calibration History
Browse and resiore calibrations. from optimizations and feature filing or mport from calibration data fies

Caibration maskers Cafbration tems
wentifer User Date MCEXPMBASED D -
Loaded from INCA C5V fle “C\sandbox\PuSunED_1... incel | 10-Feb-2021 17 UCEXPMBASED_X
"
Fited :rnn‘-‘HF]‘IE.:_nDe using dats ?ﬂ inClsandb. | moel | 11-Feb-2021 11 ::E:ﬁmg‘::;fj
Fibled from PMFINBY_inte using data fies in Claandb. | moel | 12-Feb-2021 07 WCEXPMBASES X
User marker noel 26-Fab-2021 13, WCEXPMBASES Y
MGPMREGX1_D
MGPMREGX1_X
MEPMREGXT_Y
MPMBH NOX D

For more information, see Restore Previous Calibration.
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https://www.mathworks.com/help/releases/R2021b/mbc/calibrate/fill-transient-feature.html
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Transient Calibration: Optimize calibrations of dynamic systems like
DPF and NOx controllers and OBD estimators

Use CAGE to optimize calibrations with transient controllers, which enables calibration of dynamic
systems like diesel particulate filter (DPF) and nitric oxide and nitrogen dioxide (NOx) emission
controllers, and on-board diagnostics (OBD) estimators. Specifically, CAGE can optimize calibrations
for features that:

* Include delays, discrete integrators and filters, and feedback loops.

* Contain many ( > 50) lookup tables that require estimation.

* Have multiple test data files to tune the feature.

* Require analytic derivatives to perform large-scale optimizations.

For more information, see Optimize Calibrations with Transient Controllers.

Automatic Differentiation in Feature Fills: Use analytic derivatives to
provide faster, more reliable optimizations

Feature fills use automatic differentiation (AD) to automatically calculate gradients of objective
expressions. These automatic gradients can provide faster, more reliable optimizations than the
previous default, finite-difference, approximations. When it is possible to determine the analytic
derivatives, CAGE uses AD for all feature fills.

* Large-scale optimization methods introduced in R2021a for transient calibration require AD.

*  When it is not possible to determine an analytic derivative, for example, when differentiating a
non-smooth expression, the feature fills revert to a finite-difference approach to determine the
approximate derivative.

For AD details, see Automatic Differentiation Background.

Lookup Tables: Simplified workflow for setting breakpoints and
viewing 1D optimization results

To simplify the workflow for creating lookup tables, CAGE allows you to set breakpoints and
normalizers when you create the table. Previously, to set the breakpoints, you had to create the table
and then use the Breakpoint Fill option.

Select File > New > File > 1D Lookup Table or 2D Lookup Table. Use the Create Lookup Table
dialog box to specify the following:

* Name

* Range

* Rows

* Normalizer

* Breakpoints with the Edit breakpoints option

4-2


https://www.mathworks.com/help/releases/R2021a/mbc/calibrate/fill-transient-feature.html
https://www.mathworks.com/help/releases/R2021a/optim/ug/autodiff-background.html

1D Lookup Tabl s
ookup able 4 Create Lookup Table — m] *
Mame: MNew_1D_Table
Range: (Entinf) o
Rows (V)input:  Newk 5]
Mormalizer: <hew> t
MewX nomalizer [;fEdi: breakpoints|
Input | TableOutpt
| -1] 0
[ D778, 1)
[ 0.556, 2l
0333 3l
0111 4
0.111] 5
0333 5
0556 7
0.778, 8w
ok || concar |
2D Lookup Table | —
p 4 Create Lookup Table - O X
Name: IMew_20_Table 1
Range: |
Rows (¥) input: ~ Columns (0. |NewX_1 ~|
Normalizer } v Normalizer | <Hew> v
Table raws: Table columns: | 1I]'$_
NewY normalizer: - - izer:
Input Table Output Skt breaicpomﬁd Table Qutput |
] 0]~ 5] 0] ~
0.778 s 0778 1
-0.556/ 2: -0.558) 28
0333 3l 0333 3
0111 4| 0111 4|
0.111 5 0.111 5(0
0.333 B 0.333 B
0.556 Li 0.556 7
0.778 8w 0.778 8 v
o] oo

When you view optimization results for a 1D lookup table, the Optimization Results view shows a 1D
plot. Previously, the view showed a surface view.
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For more information, see Viewing Your Optimization Results.

Feature Fill: Performance improvements when filling a single lookup
table

CAGE uses automatic differentiation to calculate the analytic derivatives during feature fill, resulting
in performance improvements when filling a single table. The automatic differentiation applies during
transient and non-transient feature fills. For more information, see Fill Feature Lookup Tables.

Feature Fill: View, edit, and optimize calibration constants

To streamline feature filling, the CAGE browser view allows control of the calibration constants.
Previously, you could only view, edit, and optimize calibration constants in the Calibration Manager.
To edit the calibration constants, in the CAGE Feature Filling view, select the Calibration Constants
tab. You can review and edit the calibration constants for the feature.


https://www.mathworks.com/help/releases/R2021a/mbc/calibrate/viewing-your-optimization-results.html
https://www.mathworks.com/help/releases/R2021a/mbc/calibrate/fill-feature-tables.html

Lookup Table Preview Calibration Constants  Validation

Name Value
Kk Constants 40
k EO_MOwx_ppm_delay_param 21.375
Kk Exhaust_flow_min 10
k Ka_AFR_max 50
k Ka_aAFR_min 2
k Ka_EGR_max 1
k Ka_EGR_min 0
k Ka_RP_max 600
k Ka_RP min 120
k Ka_sO|_max 30
k Ka_sol_min 18
k one 1
k OneTenth 0.1
k Two 2

For more information, see Feature Calibration.


https://www.mathworks.com/help/releases/R2021a/mbc/feature-calibrations.html
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Lookup Tables: Simplified workflows for filling breakpoints, smoothing
data, and accessing common tasks

Model-Based Calibration Toolbox now includes simplified workflows for filling lookup table
breakpoints, smoothing data, and accessing common tasks in CAGE.

Goal

Workflow

Optimize the lookup
table breakpoints.

On the Lookup Table view Common Tasks pane, select Breakpoints Fill. On
Breakpoint Fill Options dialog box, specify the fill options. Click OK.

4. Breakpoint Fill Options — O X
Model: WMBT ~
—I-FilBP_MBT_Start
Fill method: ShareAveCury v
Range N: 500 s000
Range L: 0.067%12 0.95016

—-ECP

Range:

Number of points: 1
—HICP

Range: 40

Number of peints: 1

The Update Lookup Tables dialog opens, allowing you to update the lookup tables with
the new breakpoints.

Previously, you had to use initialize a feature and optimize the normalizer breakpoints
to optimize the table breakpoints.

Interactively change
the smoothing factor
when you fill lookup
tables with models or
data.

On the CAGE Lookup Tables view, use the Lookup Table Smoothing interactive
control to adjust the smoothing factor.

Quickly perform
common actions,

including table filling.

On the CAGE Lookup Tables view, on the Common Tasks pane, select the
corresponding option.
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For more information, see Edit Lookup Tables.

Models: Use CAGE to import and optimize Statistics and Machine
Learning Toolbox regression models

Use CAGE to import and optimize Statistics and Machine Learning Toolbox™ regression models. For
more information, see Regression Models.

Design of Experiments: Add points for engine calibrations at
operating boundary

The Space-Filling Design browser has an option to add points at engine operating boundaries,
creating more accurate engine calibrations. In the browser, when you specify a value for Maximum
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https://www.mathworks.com/help/releases/R2020b/mbc/calibrate/edit-lookup-tables.html
https://www.mathworks.com/help/releases/R2020b/mbc/calibrate/regression-models.html
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boundary points (% of points), Model-Based Calibration Toolbox identifies operating points that
are near the constraint boundary and exterior to the constrained operating region. In the illustration,
the Exterior points to be moved are light blue. The software moves the identified points to the
constraint boundary and includes them in the constrained region. In the illustration, the Boundary
points moved are purple.
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The Maximum boundary points (% of points) option limits the maximum number of boundary
points as a percentage of the total number of design of experiment (DoE) points. The total number of
DoE points is equal to the number of interior points plus boundary points. For example:

* Ifyou set Maximum boundary points (% of points) to 100, Model-Based Calibration Toolbox
projects all Discarded exterior points onto the constraint boundary.

* Ifyou set Maximum boundary points (% of points) to 10 and the total number of DoE points is
100, the DoE will have 90 interior points and 10 boundary points. The exact number of boundary
points might be less than 10% if the software finds a sufficient number of interior points.



4| Space-Filling Design Browser

Design type:  |Sobol Seguence ~
Number of points: 219> Constraints present
Maximum boundary peints (% of points); 1 :

Options

Sequence size: 606

@ No skip

() Skip initial 2*k points

() Custom skip: ofs

|:| Apply Matousek Affine Owen scramble

Range of values:
Input Factor Min
N 5000=

L 0.06791243083|0.9501609015-%

ICP

|
en en
Ak

ECP

AH A

Preview

Generate

10 20 3D 4D

08

0.6

04

02

X-axis factor:| N

For more information, see Create a Space-Filling Design.

Model-Based Calibration Toolbox Examples: Live Scripts for engine
calibration, design of experiment, and engine modeling examples

Model-Based Calibration Toolbox includes live scripts for these engine calibration, design of
experiment, and engine modeling examples:

* https://www.mathworks.com/help/releases/R2020b/mbc/mbc_gs/use-constraints.html

* https://www.mathworks.com/help/releases/R2020b/mbc/mbc_gs/local-design.html

* https://www.mathworks.com/help/releases/R2020b/mbc/mbc_gs/optimal-design.html

* https://www.mathworks.com/help/releases/R2020b/mbc/mbc_gs/gasoline-case-study.html

* https://www.mathworks.com/help/releases/R2020b/mbc/mbc_gs/gasoline-case-study-doe.html
* https://www.mathworks.com/help/releases/R2020b/mbc/mbc_gs/load-and-modify-data.html

* https://www.mathworks.com/help/releases/R2020b/mbc/mbc_gs/point-by-point-modeling-for-

diesel.html

Previously, the examples were plain code scripts.

Automatically update preview

1000 2000 3000 4000 5000 6000



https://www.mathworks.com/help/releases/R2020b/mbc/model/creating-a-space-filling-design.html
https://www.mathworks.com/help/releases/R2020b/mbc/mbc_gs/use-constraints.html
https://www.mathworks.com/help/releases/R2020b/mbc/mbc_gs/local-design.html
https://www.mathworks.com/help/releases/R2020b/mbc/mbc_gs/optimal-design.html
https://www.mathworks.com/help/releases/R2020b/mbc/mbc_gs/gasoline-case-study.html
https://www.mathworks.com/help/releases/R2020b/mbc/mbc_gs/gasoline-case-study-doe.html
https://www.mathworks.com/help/releases/R2020b/mbc/mbc_gs/load-and-modify-data.html
https://www.mathworks.com/help/releases/R2020b/mbc/mbc_gs/point-by-point-modeling-for-diesel.html
https://www.mathworks.com/help/releases/R2020b/mbc/mbc_gs/point-by-point-modeling-for-diesel.html
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Simulink Integration: Simplified workflows for importing lookup tables
and features and exporting data dictionaries

Model-Based Calibration Toolbox now includes these simplified workflows for importing lookup tables
from Simulink models into CAGE and exporting data dictionaries.

6-2

Goal Using Workflow

Fill Simulink Statistical models |1 In the CAGE browser, select Simulink Lookup Tables.
lookup tables and |or optimization

export data to results YT —— a3

Simulink model [ NG TE ‘

workspace. =B ’

Import lockup ables
from Simulink model.
Fill lookup tables using
a model or optimization
results.

Simulink Lookup Tables

Select the Simulink model.

2 Use the MBC Simulink Lookup Table Importer to preview and
import all lookup tables in a subsystem. Click Import Tables to
import tables into CAGE.

3 In CAGE, fill the lookup tables using statistical models or
optimization results.

4 To export the calibration to a Simulink model workspace or data

dictionary, select File > Export > Calibration. Set Export to to
Simulink Data.

For more information, see Import Lookup Tables from a Simulink
Model.



https://www.mathworks.com/help/releases/R2020a/mbc/calibrate/import-lookup-tables-from-a-simulink-model.html
https://www.mathworks.com/help/releases/R2020a/mbc/calibrate/import-lookup-tables-from-a-simulink-model.html

Goal

Using

Workflow

Feature calibration

1 In the CAGE browser, select Feature Filling.

L T

Import strategy from
Simulink to calibrate
estimation algorithm

)

Feature Filling

Select the Simulink model.

2 Use the MBC Feature Importer to preview tables and import the
features for the selected subsystems. Click OK.

3 In CAGE, fill the lookup tables using feature fill.

To export the calibration to a Simulink model workspace or data
dictionary, select File > Export > Calibration. Set Export to to
Simulink Data.

For more information, see Set Up Feature and Strategy and Calibrate
a Feature for an Estimator Subsystem in an ECU.

Compatibility Considerations

In R2020a, to export a calibration to a Simulink model workspace from CAGE, select File > Export >
Calibration and set Export to to Simulink Data. This replaces the Simulink Model Workspace
parameter setting for Export to.
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https://www.mathworks.com/help/releases/R2020a/mbc/calibrate/set-up-feature-and-strategy.html
https://www.mathworks.com/help/releases/R2020a/mbc/calibrate/calibrate-a-feature-for-an-estimator-subsystem-in-an-ecu.html
https://www.mathworks.com/help/releases/R2020a/mbc/calibrate/calibrate-a-feature-for-an-estimator-subsystem-in-an-ecu.html
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Optimization Progress: View result surface tables during optimization

The Optimization Progress dialog box provides the status of the optimization in progress, including
the results surface tables.

Optimization Objective

Progress Dialog Box

Point

The dialog box provides the
number of completed and
acceptable operating point
solutions. You can change the
axes to view a specific result

surface as the optimization runs.

4 Optimization Progress - TPA_Optimization

Operating point 125, Completed 125214 (125 acceptable)

Y-axis: |n A

X-axis:

Trg e

Z-axis: |TPA

Stop

Cancel
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Optimization Objective

Progress Dialog Box

Sum

In the dialog box, the trace lines
provide this additional
optimization information.

Trace Color |Description

Black Objective

Red Maximum
constraint
violation

You can change the axes to view
a specific result surface as the
optimization runs.

4\ Optimization Progress - Sum_Torque_Optimization

Computing optimal settings

1415 - T

Taorgue

Spead

M-axis: |LOAD

1000 0.2

Y-axis. |Speed

0.4

S

1
0.8
0.6

LoaD

Z-axis. | Torgue

Stop

Maximum conslrainl

1.2

S

Cancel

Performance: Improved optimization performance with default
settings and algorithms

To improve optimization performance, R2019b includes these updates.
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Update

Default settings

Default settings for these optimization algorithms.

fmincon

modal

GA
patternsearch
gamultiobj
NBI
paretosearch
multistart

Default algorithms for point and sum optimizations.

sqp algorithm for point optimizations
interior-point algorithm for sum optimizations




Update

Setting for sum optimizations that use the fmincon algorithm. By default, the
optimization option Make table gradient constraints feasible is enabled.

4. Optimization Parameters — O >
= fmincon

Censtrained optimization algorithm: interior-point v

Dizplay: none A

Maximum iterations: 2000

Maximum function evaluations: 20000

Function tolerance: 1e-06

‘ariable tolerance: 1e-10

Constraint tolerance: 1e-06

Number of start points: 1

Run from feasible start points only: |:|

Soft constraints weighting:: 1

Make table gradient constraintz feasible: I/\\"g

Mozt recent versi
Cancel

Model-Based Calibration Toolbox tries to satisfy the table gradient constraints before the
fmincon algorithm begins optimizing. For more information, see Edit Optimization
Parameters.

Model-Based Calibration Toolbox sets advanced optimization options that depend on the number of
optimization variables and constraints.

Optimization Solutions: Use soft constraints to find feasible
optimization solutions

When you specify a soft constraint, Model-Based Calibration Toolbox does not require that the
optimization satisfies the constraint. Instead, Model-Based Calibration Toolbox allows for some slack
around the constraint. During the optimization, the algorithm satisfies the soft constraint by
minimizing the slack and optimizing the objective. Consider specifying soft constraints when the:

* Constraint bounds are not well understood.
* Optimization has difficulty finding feasible solutions with hard constraints.

To specify a soft constraint, in CAGE, on the Constraints pane, select Soft Constraint.
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Constraints

Mame De=scription Type Soft Constraint

h Torgue Boundary | Boundary constraint of Torgue(ECP, ICP...| Model |:|

i KIT1(ECF, ICP, LOAD, Speed) <= 2 Model U
